eComsta Requirements


  • Unix/Linux/Windows/MaxOS X Server
  • PHP Version 7.2 or higher
  • MySQL 5.6 or above (InnoDB support required)
  • PHP IonCube Loader Extension
  • PHP Curl Extension
  • PHP Exif Extension - GoClixy uses this extension to check the orientation of an image uploaded through the iPhone.
  • PHP ICONV (php-iconv) - For Captcha
  • PHP Finfo Extension - For File Manager Thumbnail Generation (the mime_magic extension must be set to on).
  • PHP ZIP - For Bulk Import/Export and Version Files Update
  • The allow_url_fopen must be set to 0 in php.ini file (allow_url_fopen=0) for YouTube Videos section.
  • To use SEO URLs, you must have the Apache mod_rewrite extension installed.

NOTE: In MySQL 5.7.5 and up, the ONLY_FULL_GROUP_BY SQL mode is enabled by default, you need to contact your Hosting Provider to disable this option.

If you are doing the installation on a local computer, a number of packages can be used to set up GoClixy quicker than individual installations:

Recommended Hosting: